My SharePoint 2010 VM

Back in November 2009, I built my SharePoint 2010 VM from scratch with the following hardware

Intel Core i5 Quad Core 2.67Ghz
8GB Ram
2 Hard Drives

Software
Windows 7 64-bit (Host OS)
VMWare Server 2.01

Virtual Machine:
Windows 2008 Sever R2
SharePoint 2010 beta 2
Visual Studio 2010 beta
Office 2010 beta

Remarks:
I am using (free) VMware Server 2.01 rather than Microsoft’s Virtual PC 2007 to host my SharePoint 2010 beta. VPC 2007 is not supported by Microsoft on Windows 7, therefore my reason to try and learn VMware.

VMware Glitches:
1. Sometimes I receive an error to the login screen to  the VWware Infrastructure Web Access via internet browsers. I don’ t now the solution yet, but I just close browser and try again.
2. I installed VMware plug-ins to the VM with win2008 server R2, the whole remote desktop console freezes if I use mouse scroll wheel. I uninstalled the plug-ins and issue never occurs.

Performance:
Running 2 VM’s and keeping memory consumption under 8GB tends to be pretty good, but can be better. I think if I had a solid state hard drive for my VM images, I think it would make the performance much better. I would like to buy a solid state drive sometime later this year.

Advertisements

4 thoughts on “My SharePoint 2010 VM

    1. Hi Divya,

      Firs of all, according to my blog post, I used VMWare to setup my VM; rather than HyperV.
      But the issue sounds like virtualization is not configured.
      Check
      1) Your cpu has virtualization technology
      2) If so, configure the BIOS to enable virtualization support
      3) Do a cold reboot. Fully turn off computer and turn back on.

      Let me know if this helps.

      Roy

  1. Hi Roy,

    Thanks for updates, i check in the Bios of the server virtualization technology enabled and DEP. I tried to do it twice, which was not helping me at all, so i tried solution as you suggest to create Virtual machine, i created using Virtual Box , i found that Virtual box is not allowing to share my server files inside built in VM machine, my purpose is to install patches required for Sharepoint 2010 because i am unable to create ISO image of those. If you have any idea, please suggest how i can open my shared Folder inside Virtual Box

    Thanks in Advance
    Divya

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s