Installing SharePoint 2013 Preview “Server Unavailable” Issue

Issue: After Installation of SP 2013 Preview, Central Administration Web Site resulted in error message “Server Unavailable” and also in the Event Logs with “The worker process failed to pre-load .Net Runtime version v4.0.21006.”

Context: I have a VM copy of a bare installation of SP 2010 with Windows Server 2008R2 and SQL Server 2008 R2. My goal is to install and “overwrite” with SP 2013

My steps
1. Install Windows Server 2008 SP1 and SQL Server 2008 SP1 and SP2
2. Install SP 2013 Preview Prequisites
3. Install SP 2013 Preview Setup
4. Configure new server farm installation
5. Configure for Central Administration web site
6. Loading Central Administration web site resulted in issue

I thought that App pool identity credential’s were incorrect but that was not the issue as many would have thought.

Resolution:

1. Go to “C:\Windows\System32\inetsrv\config” and open applicationHost.config
2. Look for <applicationPools>
3. Look for App Pools with name related to SharePoint especially “SharePoint Central Administration”
4. Change managedRuntimeVersion=”v4.0” to “v4.0.30319”
5. Run iisreset

Note: I have tried to change the runtime version through inetmgr UI, but the drop down selection

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s