SharePoint Designer 2013 | Publishing 2013 Workflow Error

Using SharePoint Designer 2013, I create and publish a simple custom workflow (2013 platform). I get the following within the error message:

“There was no endpoint listening at net.pipe://localhost/SecurityTokenServiceApplication/appsts.svc that could accept the message.”

Background:

  • I am able to browse to http://localhost:32843/SecurityTokenServiceApplication/securitytoken.svc with no issues or errors showing.
  • I have installed Worfklow Manager (and update) on a WFE server in a 3 tier setup.
  • I am trying to publish this through a domain account which was not used to install, but is still local administrator and Site Collection administrator.
  • The net.pipe binding exists in IIS web site for SharePoint Web Services
  • Windows Server 2012, installed all WF updates, SP server updates, SP Designer update

Solution:

Windows Services -> Start the Net.Pipe Listener Adapter service

Service Description: Receives activation requests over the net.pipe protocol and passes them to the Windows Process Activation Service.

I just stumbled upon this service by associating the name “Net.Pipe” and the error message containing “There was no endpoint listening at net.pipe://…”

What is “net.pipe”?

netNamedPipeBinding binding, which provides cross-process communication on the same machine. Named pipes do not work across machines.”

Advertisements

4 thoughts on “SharePoint Designer 2013 | Publishing 2013 Workflow Error

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s